CMSimple 5.2 - ready for php 8

CMSimple 4.0 und höher
Post Reply
Gert
Posts: 1435
Joined: Sun 18. Nov 2012, 14:18

CMSimple 5.2 - ready for php 8

Post by Gert » Mon 4. Jan 2021, 13:15

Image Hallo,

CMSimple 5.2 steht zum Download bereit.

CMSimple 5.2 ist "ready for php8". CMSimple 5.2 und alle Plugins von ge-webdesign.de wurden getestet unter php 8.0.0.

Ein Update CMSimple 4.0 => 5.2, mit dem alle CMSimple Installationen ab 4.0 problem- und schmerzlos aktualisiert werden können, steht auch wieder zur Verfügung. CMSimple 4 Seiten laufen nach einem Update auf CMSimple 5.1 einfach weiter wie gewohnt, im CMSimple 4 Modus, mit dem alten Seitensplitting.

ChangeLog: https://www.cmsimple.org/?Downloads___ChangeLog

Download: http://www.cmsimple.org/?Downloads___CMSimple

Viel Spass - Gert

==========================================================

Image Hello,

CMSimple 5.2 is ready for download.

CMSimple 5.2 is "ready for php 8". CMSimple and all Plugins from ge-webdesign.de was tested under php 8.0.0.

An Update CMSimple 4.0 => 5.2, for an easy and painless update of all installations of CMSimple 4.0 or higher, also is available. After an update to CMSimple 5.1, CMSimple 4 pages continue to run as usual, in CMSimple 4 mode, with the old pagesplitting method.

ChangeLog: https://www.cmsimple.org/en/?Downloads___ChangeLog

Download: http://www.cmsimple.org/en/?Downloads___CMSimple

Have fun - Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

meyomey
Posts: 24
Joined: Tue 17. May 2016, 11:52
Contact:

Re: CMSimple 5.2 - ready for php 8

Post by meyomey » Sat 9. Jan 2021, 16:03

Hallo Gert,
wünsche Dir und allen anderen noch ein frohes und insbesondere gesundes neues Jahr! :)

Ich habe mal versucht unsere Webseite auf php 8.0.0 umzustellen und deshalb CMSimple und Plugins auf neuesten Stand gebracht.

1. Problem gibt es mit Mailforms 2.2. Eine E-Mail wird nicht verschickt, nach dem Absenden erscheint nur eine Seite ohne Inhalt.
Nach Zurückstellen auf php 7.4.12 funktioniert alles wieder.

2. Problem: Bei aktiviertem SubsiteFuncs 2.1, erscheint die Webseite ebenfalls ohne Inhalt (komplett weiß) mit php 8.0.0, mit 7.4.12 ist`s ok.

Unsere Vereinsseite unter php.8.0.0 ist testweise hier zu finden: test.wulmstorf.net

Viele Grüße
Heiko

PS: Bedanken möchte ich mich noch für deine stetige und gute Weiterentwicklung von CMSimple sowie für deinen tollen und schnellen Support! :D

meyomey
Posts: 24
Joined: Tue 17. May 2016, 11:52
Contact:

Re: CMSimple 5.2 - ready for php 8

Post by meyomey » Sat 9. Jan 2021, 17:29

Hallo Gert,

das ist die dazugehörige Debugging Fehlermeldung nach Absenden des Formulars:
Fatal error: Uncaught Error: Call to undefined function get_magic_quotes_gpc() in /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/mailforms/dd-formmailer.php:447 Stack trace: #0 /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/mailforms/dd-formmailer.php(1221): ddfm_stripslashes('') #1 /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/mailforms/index.php(78): include_once('/var/www/vhosts...') #2 /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/mailforms/index.php(40): dd_mailform('_replaceSMF', NULL, '') #3 /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/index.php(304): include('/var/www/vhosts...') #4 /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/cmsimple/cms.php(515): include('/var/www/vhosts...') #5 /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/index.php(3): include('/var/www/vhosts...') #6 {main} thrown in /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/mailforms/dd-formmailer.php on line 447

Gert
Posts: 1435
Joined: Sun 18. Nov 2012, 14:18

Re: CMSimple 5.2 - ready for php 8

Post by Gert » Sat 9. Jan 2021, 17:32

Hallo Heiko,

vielen Dank fürs testen :)

zu 1.: Tatsächlich :oops:

Lade bitte MailForms noch einmal runter und ersetze die dd-formmailer.php, wenn es dann läuft, werde ich MailForms 2.3 veröffentlichen.

zu 2.: Bei mir läuft SubsiteFuncs ohne Probleme unter php 8.0.0. Hast du den DebugMode aktiviert? Dann bekommst du evtl. ein paar Fehlermeldungen, die Du dann hier posten kannst,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

meyomey
Posts: 24
Joined: Tue 17. May 2016, 11:52
Contact:

Re: CMSimple 5.2 - ready for php 8

Post by meyomey » Sat 9. Jan 2021, 18:05

Hallo Gert,

zu 1.:
Mit der neuen dd-formmailer.php funktioniert`s :D

zu 2.:
Folgende Fehlermeldung erscheint wenn SubsiteFuncs aktiviert ist:
Fatal error: Uncaught TypeError: sort(): Argument #1 ($array) must be of type array, null given in /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/subsitefuncs/index.php:99 Stack trace: #0 /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/subsitefuncs/index.php(99): sort(NULL) #1 /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/index.php(304): include('/var/www/vhosts...') #2 /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/cmsimple/cms.php(515): include('/var/www/vhosts...') #3 /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/index.php(3): include('/var/www/vhosts...') #4 {main} thrown in /var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/subsitefuncs/index.php on line 99

Aufgefallen sind mir noch zwei Fehlermeldungen zu RealBlog im Backend:
WARNING: 2 Undefined array key -1
/var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/realblog/index.php:645
WARNING: 2 Undefined array key -1
/var/www/vhosts/hosting139268.a2e64.netcup.net/test.wulmstorf.net/plugins/realblog/index.php:771
Heiko

Gert
Posts: 1435
Joined: Sun 18. Nov 2012, 14:18

Re: CMSimple 5.2 - ready for php 8

Post by Gert » Sat 9. Jan 2021, 19:24

Hallo Heiko,

gleiche Prozedur mit SubsiteFuncs 2.1: neu runterladen und index.php austauschen. Und Feedback geben ;)

Zur Erklärung: Das passiert, weil Du noch gar keine Subsite angelegt hast, und auch die Vorlageordner nicht mit hochgeladen hast. Soll man ja auch nicht ;)

In meiner Entwicklungsumgebung ist aber beides, Subsites und Vorlage, vorhanden, und deshalb ist das bei meinen Tests nicht aufgetreten.

Zu RealBlog: Die Ursache ist, dass Du RealBlog auf der Startseite laufen hast. Und es passiert auch nur, wenn mehr Beiträge vorhanden sind, als auf die 1. Blogseite passen. Da muss also schon einiges zusammenkommen, bei meinen Tests habe ich diesen Zustand nicht erreicht.

Ich könnte jetzt die Warnungen mit @ unterdrücken, das mache ich aber ungern. Vorerst musst Du also mit den beiden Warnungen im Backend leben, aber ich denke nochmal drüber nach.

Jetzt habe ich was zu tun übers Wochenende :mrgreen:

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

meyomey
Posts: 24
Joined: Tue 17. May 2016, 11:52
Contact:

Re: CMSimple 5.2 - ready for php 8

Post by meyomey » Sat 9. Jan 2021, 21:25

Hallo Gert,

alles bestens nach Austausch der index.php. Die Seite wird wieder vollständig angezeigt. :)
Das Plugin SubsiteFuncs ist auch nur eine Altlast in meiner Installation, welches ich nicht mehr nutze.
Ich habe jetzt auch mal an die anderen gedacht, die dieses Plugin einsetzen... ;)

Die Warnungen betreffend Realblog stören mich nicht wirklich.

Schönes Restwochenende :lol:
Heiko

Gert
Posts: 1435
Joined: Sun 18. Nov 2012, 14:18

Re: CMSimple 5.2 - ready for php 8

Post by Gert » Sat 9. Jan 2021, 21:49

meyomey wrote:
Sat 9. Jan 2021, 21:25
Die Warnungen betreffend Realblog stören mich nicht wirklich.
Aber mich ;)

Auch RealBlog habe ich jetzt soweit, dass es keine Warnungen mehr wirft, auch wenn es auf der Startseite läuft.

Ich habe RealBlog nochmal gründlich getestet und auch noch Probleme in den Funktionen showrealblogarchive() und realbloglink() und mit der Sortierung der Artikel in der Vorschau gefunden und gelöst. Morgen sind dann also neue Versionen von 3 Plugins zu veröffentlichen :roll:

Also dann - vielen Dank nochmal für die Tests und das Feedback,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

Post Reply