saving in CMS setting

CMSimple 4.0 und höher
Post Reply
roze
Posts: 22
Joined: Wed 18. Sep 2013, 11:03

saving in CMS setting

Post by roze »

I want to save something in my CMS setting.

I click on <save> ant then a page "Testing 123, this is an apache http server test powered bit CentOS etc...." . and nothing is saved.......

What is wrong with my settings?

https://www.stichtingvaart.nl
Rob | Valkenswaard NL
Gert
Posts: 2123
Joined: Sun 18. Nov 2012, 14:18

Re: saving in CMS setting

Post by Gert »

Hello,

seems to be a server problem.

1. ask google for "Testing 123 apache CentOS"

2. ask your provider or your server admin (who is it?)

3. does it happen only by saving CMS config? Try languages, plugin configs and languages etc.

4. What appears in your browser's address bar after saving?

5. have you activated the debug mode?

6. try it in a fresh installation in a subfolder, is there the same problem?

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services
roze
Posts: 22
Joined: Wed 18. Sep 2013, 11:03

Re: saving in CMS setting

Post by roze »

1. ask google for "Testing 123 apache CentOS"
hmm, I get pages that aren't helpful for me
2. ask your provider or your server admin (who is it?)
I've made a service ticket with this question
My webhoster is www.Yourhosting.nl
3. does it happen only by saving CMS config? Try languages, plugin configs and languages etc.
all the 'savings' does give the same result: testing 123. But I can make a new page and save that!
4. What appears in your browser's address bar after saving?
www.stichtingvaart.nl
5. have you activated the debug mode?
Yes.
when I open the CMS configuration page it says:

Code: Select all

WARNING: 2 Undefined array key "csrf_token___"
/home/stichtingvaart.nl/public_html/cmsimple/adm.php:772
6. try it in a fresh installation in a subfolder, is there the same problem?
yes, the same problem. www.nieuw.stichtingvaart.nl
Rob | Valkenswaard NL
Gert
Posts: 2123
Joined: Sun 18. Nov 2012, 14:18

Re: saving in CMS setting

Post by Gert »

roze wrote: Mon 20. May 2024, 12:38 WARNING: 2 Undefined array key "csrf_token___"
/home/stichtingvaart.nl/public_html/cmsimple/adm.php:772
Could you please post the line 772 of your adm.php?

Should be:

Code: Select all

if($cf['use']['csrf_protection'] == 'true') $o .= '<input type="hidden" name="csrf_token" value="' . $_SESSION[$csrfSession] . '">' . "\n";
Is "Use => Csrf_protection:" activated ("true") in the CMS config?

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services
roze
Posts: 22
Joined: Wed 18. Sep 2013, 11:03

Re: saving in CMS setting

Post by roze »

this is line 772 of the admin.php

Code: Select all

if($cf['use']['csrf_protection'] == 'true') $o .= '<input type="hidden" name="csrf_token" value="' . $_SESSION[$csrfSession] . '">' . "\n";
Is "Use => Csrf_protection:" activated ("true") in the CMS config?
Yes: true
Rob | Valkenswaard NL
Gert
Posts: 2123
Joined: Sun 18. Nov 2012, 14:18

Re: saving in CMS setting

Post by Gert »

roze wrote: Mon 20. May 2024, 13:26Yes: true
Set it to empty (offline, and upload by ftp) and try again.

I will be offline now for some hours,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services
roze
Posts: 22
Joined: Wed 18. Sep 2013, 11:03

Re: saving in CMS setting

Post by roze »

Gert,

Unfortunately it makes no difference..

"true" => ""

I put it back again to "true"
Rob | Valkenswaard NL
Gert
Posts: 2123
Joined: Sun 18. Nov 2012, 14:18

Re: saving in CMS setting

Post by Gert »

Sorry, but I have no idea what happens on your server ...

The only way would be FTP access to your test installation nieuw.stichtingvaart.nl, so I could do some testing to see if I find a solution for such servers. You could send me the access data via PM,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services
Gert
Posts: 2123
Joined: Sun 18. Nov 2012, 14:18

Re: saving in CMS setting

Post by Gert »

Hi Rob,

Thanks for the possibility to test on your server.

ModSecurity was the troublemaker once again, considers the term "cmsimpleDataFileStored" in adm.php as an attack :roll:

I have solved it on your server and will rename "cmsimpleDataFileStored" to "cmsimpleDataStored" :roll: also in the next version of CMSimple,

thanks again - Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services
Post Reply