Plugin Bildergalerie auf localhost

CMSimple 4.0 und höher
berni51
Posts: 10
Joined: Sun 23. Nov 2014, 19:39
Location: Am Rande des Vogelsberges
Contact:

Plugin Bildergalerie auf localhost

Postby berni51 » Tue 25. Nov 2014, 09:36

Liebe Freunde der einfachen Lösungen,

meine CMSimple 4.45 Installation teste ich auf einem Linux-System, also auf localhost. Bisher funktioniert da alles und ich übertrage es dann ruhigen Gewissens auf den Server meines Providers.

Nun habe ich local Versuche mit dem Plugin Bildergalerie gemacht. Zunächst sieht alles sehr gut aus, die Demo-Galerie wird ordentlich angezeigt und ich kann neue Galerien erstellen.
Was aber nicht geht, ist das Hinzufügen von Bildern! Weder einzelne Bilder noch Bilder aus dem Uploads-Ordner werden hochgeladen. Alle Versuche enden in einem weissen, leeren Browserbildschirm ohne irgendeine Meldung. Auch wenn ich dem System viel zeit gebe, passiert einfach nicht. Ich kann dann den Vorgang beenden, indem ich die ZURÜCK-taste des Browsers anklicke. Aber die Galerien enthalten dann immer noch keine Bilder bzw. bei der Demo-Galerie nicht mehr als vorher.

Ist das ein Problem mit localhost? Die Berechtigungen habe ich entsprechend der Doku vergeben.

Hilflos im Vogelsberg

Berni

Gert
Posts: 1092
Joined: Sun 18. Nov 2012, 14:18

Re: Plugin Bildergalerie auf localhost

Postby Gert » Tue 25. Nov 2014, 11:29

Hallo Berni,

ich kenne mich mit Linux nicht aus, und ich weiss nicht, was Du als Localhost verwendest. Funktioniert es auf dem Webserver (online)?

Das Plugin FotoGalerie (Ich vermute einfach mal, dass Du das mit "Bildergalerie" meinst) braucht GDlib (GD Library). Ich empfehle als Localhost Xampp:

https://www.apachefriends.org/de/download.html

Da ist die GDlib standardmässig aktiviert.

Berni51 wrote:Alle Versuche enden in einem weissen, leeren Browserbildschirm ohne irgendeine Meldung.

FAQ: http://www.cmsimple.org/forum/viewtopic.php?f=20&t=443

Gert

PS: mit korrekten Angaben kannst Du den Grad der Hilfsbereitschaft erhöhen. In diesem Fall also:

FotoGalerie 7.2 in CMSimple 4.4.5

Und vielleicht noch:
Localhost ... (z. B. Xampp unter Linux)
PHP Version ...
usw.
Gert Ebersbach | CMSimple | Templates - Plugins - Services

berni51
Posts: 10
Joined: Sun 23. Nov 2014, 19:39
Location: Am Rande des Vogelsberges
Contact:

Re: Plugin Bildergalerie auf localhost

Postby berni51 » Tue 25. Nov 2014, 12:56

Mist, schon wieder unvollständige und ungenaue Angaben :oops:

Als Webserver läuft hier der apache und PHP5 ist installiert.
Bei aktiviertem debug Modus gibt es diese Fehlermeldung:
Fatal error: Call to undefined function ImageCreateFromJPEG() in /var/www/html/CMSimple_445/plugins/fotogalerie/admin.php on line 87

Auf dem Server des Providers hab die fotogalerie noch nicht installert, aus Angst, mir etwas zu zerschiessen. Deshalb der test auf localhost. Aber wahrscheinlich hab ich keine saubere Testumgebung hier laufen. Jetzt geh ich mal auf die Suche nach der GD Library.

Schon mal besten Dank für den Support.

Grüße

Berni

berni51
Posts: 10
Joined: Sun 23. Nov 2014, 19:39
Location: Am Rande des Vogelsberges
Contact:

Re: Plugin Bildergalerie auf localhost

Postby berni51 » Tue 25. Nov 2014, 14:35

Die Lösung: Eine fehlende GD-Bibliothek! Und, ganz wichtig: Danach den Apache neustarten. Das hatte ich nämlich vergessen.

Die Schritte dazu waren auf der Linux Kommandozeile:

# sudo apt-get install php5-gd
# sudo apachectl -k restart

Danke an die Supporter Christoph und Gert.
Und hinsichtlich korrekter Daten gelobe ich Besserung.

Gert
Posts: 1092
Joined: Sun 18. Nov 2012, 14:18

Re: Plugin Bildergalerie auf localhost

Postby Gert » Tue 25. Nov 2014, 15:02

Hallo Berni,

Du solltest wissen, dass Christoph für mich ein rotes Tuch ist.

Ich habe ihm aus gutem Grund den Zutritt zu diesem Forum verwehrt, und es ist für ihn immer wieder ein innerer Abgang, wenn er es schafft, sich hintenrum hier einzuschleichen. Wenn Du einer von Christophs Verehrern werden willst, bist Du hier falsch. Der hat ein eigenes CMS mit einem eigenen Forum. Er zieht gerne Anwender aus diesem Forum zu seinem Fork, indem er sie anschreibt, sobald er die Website kennt. Du bist nicht der erste.

Das konntest Du natürlich nicht wissen, deshalb dieser Hinweis. Und es ist mir zu doof, das hinter den Kulissen zu machen, ich bin diesbezüglich für Offenheit.

Wenn Du Dich also bei Christoph für irgendwas bedanken willst, solltest Du das in Zukunft auf dem Weg tun, auf dem er sich diesen Dank verdient hat ;)

berni51 wrote:Und hinsichtlich korrekter Daten gelobe ich Besserung.

Kein Problem, Du bist ja neu hier und musst erstmal ein Gefühl dafür bekommen, welche Angaben gebraucht werden ;)

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

berni51
Posts: 10
Joined: Sun 23. Nov 2014, 19:39
Location: Am Rande des Vogelsberges
Contact:

Re: Plugin Bildergalerie auf localhost

Postby berni51 » Tue 25. Nov 2014, 16:17

Oha, unerfreuliche Interna. Hab ich nicht gewusst - woher auch.
Möchte ich mich auch gar nicht reinhängen - mein CMSimple läuft und jetzt auch die Fotogalerie.

Grüße

Berni

Gert
Posts: 1092
Joined: Sun 18. Nov 2012, 14:18

Re: Plugin Bildergalerie auf localhost

Postby Gert » Tue 25. Nov 2014, 16:36

berni51 wrote:Hab ich nicht gewusst - woher auch.

Kein Problem ;)

berni51 wrote:mein CMSimple läuft und jetzt auch die Fotogalerie.

Freut mich zu hören, das ist ja das wichtigste.

Erstaunlich finde ich nur, dass bei Deinem Xampp die GDlib nicht installiert oder nicht aktiviert war. Bisher war die GDlib bei jeder meiner Xampp Installationen per default aktiviert. Aber das waren Windows Installationen, kann ja sein, dass das bei Linux anders ist.

berni51 wrote:Auf dem Server des Providers hab die fotogalerie noch nicht installert, aus Angst, mir etwas zu zerschiessen.

Du kannst auch in einem anderen Unterverzeichnis des online-Servers eine Test- oder Arbeitsinstallation von CMSimple installieren, da kann eigentlich nix passieren, solange Du nur CMSimple und Standardkomponenten (Plugins und Templates) verwendest,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

berni51
Posts: 10
Joined: Sun 23. Nov 2014, 19:39
Location: Am Rande des Vogelsberges
Contact:

Re: Plugin Bildergalerie auf localhost

Postby berni51 » Tue 25. Nov 2014, 17:19

Gert wrote:Erstaunlich finde ich nur, dass bei Deinem Xampp die GDlib nicht installiert oder nicht aktiviert war. Bisher war die GDlib bei jeder meiner Xampp Installationen per default aktiviert. Aber das waren Windows Installationen, kann ja sein, dass das bei Linux anders ist.
Gert


Ist eigentlich gar nicht erstaunlich, weil ich Xampp nicht benutzt habe, sondern die notwendigen Server wie apache und php5 direkt installiert und konfiguriert habe. Hätte ich Xampp benutzt, hätte ich vermutlich das Problem gar nicht gehabt. ;)

Gruß

Berni

Gert
Posts: 1092
Joined: Sun 18. Nov 2012, 14:18

Re: Plugin Bildergalerie auf localhost

Postby Gert » Tue 25. Nov 2014, 17:42

berni51 wrote:Und, ganz wichtig: Danach den Apache neustarten.

berni51 wrote:Hätte ich Xampp benutzt, hätte ich vermutlich das Problem gar nicht gehabt. ;)

Oh - da habe ich den Apache mit Xampp gleichgesetzt - Fehldeutung meinerseits ...

berni51 wrote:... sondern die notwendigen Server wie apache und php5 direkt installiert und konfiguriert habe.

An sowas habe ich mich bis jetzt noch nicht rangetraut. Warum auch - gibt ja Xampp ;)

Wäre bestimmt interessant - aber zeitlich absolut nicht möglich, da ist IMMER was anderes wichtiger ;)

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services


Return to “CMSimple 4.0 and higher”

Who is online

Users browsing this forum: No registered users and 2 guests