Page 1 of 1

CMSimple 2.9 and PHP 5.6

Posted: Tue 24. Feb 2015, 13:58
by Erik Lomholt-Bek
My webhotel provider one.com have updated to PHP 5.6, and now my webpage http://www.boatc.dk cant show the danish æøå any longer. Is it their updateing thats gone wrong, or can the older CMS 2.9 not be used with PHP5.6.
Is there any easy way to fix that, or do i have to upgrade to the CMS 4.5 ?

Re: CMSimple 2.9 and PHP 5.6

Posted: Tue 24. Feb 2015, 14:22
by Gert
Hello,

it's a miracle, that you see anything from your website after upgrading to PHP 5.6 ... CMSimple 2.9 is very old and unsafe.

The best solution is, to install CMSimple 4.5.1 and insert your contents to the new installation.

Consider, that you have to rename your old content.htm to content.php, and convert it to utf-8 without BOM:

http://www.cmsimple.org/doku/en/?Update_from_old_versions___Install_CMSimple_4.0

The reason for your problem probably is, that the new php version delivers utf-8, but CMSimple 2.9 is ANSI encoded, probably all, template AND content.htm - of course you can convert all files to utf-8 without BOM, but that will not solve the real problem with CMSimple 2.9.

But it is very interesting, that CMSimple 2.9 is running under php 5.6 ...

Gert

Re: CMSimple 2.9 and PHP 5.6

Posted: Wed 25. Feb 2015, 01:21
by meltemi
Erik wrote:Is there any easy way to fix that

Hej,

I can see your danish letters very well after changing my browser view to ISO-8859-1: No problem from your cms :-)

Perhaps your web hoster has changed default charset from ISO-8859-1 to UTF-8 at the same time when updating to PHP 5.6 (but these are two different changes).

Ask the web hoster, wether you can use file .htaccess and determine you charset like this (or similar):

Code: Select all

AddDefaultCharset ISO-8859-1

In your source code I see CMSimple 3.2, not 2.9.

Re: CMSimple 2.9 and PHP 5.6

Posted: Sat 7. Mar 2015, 22:21
by Erik Lomholt-Bek
my webhost wrote me:


Changing the default charset

If you have special characters like æøåäüö that are displayed wrong on your web pages, you can add one of the following lines to your .htaccess file to see if it fixes the problem. You should add the first line and if this does not work, you should try the other line. You should not add both.

AddDefaultCharset ISO-8859-1
AddDefaultCharset UTF-8


But i cant get it to Work.

Re: CMSimple 2.9 and PHP 5.6

Posted: Sun 8. Mar 2015, 00:01
by meltemi
Hej Erik,

now you have updated to CMSimple 4.5.1, and now charset UTF-8 is the correct one (no longer ISO-8859-1). When using CMSimple 2.9, charset ISO-8859-1 would be the correct one.

The sent HTTP header from your server is correct (for CMSimple 4.5.1):

Code: Select all

Content-Type:·text/html;·charset=utf-8(CR)(LF)

Look here: http://tinyurl.com/mpqyydu

I don't see any æøåäüö on your start page, but the default start page from Gert in English. And in English there are no letters like æøåäüö, as far as I know ;-)


P.S.:
Just seen on your /?Menu_levels...-Page:
strømstedet førstefjord
Ørredfiskeri Akornga
VEDTÆGT

This looks like Dansk :-)

Re: CMSimple 2.9 and PHP 5.6

Posted: Sun 8. Mar 2015, 00:55
by Erik Lomholt-Bek
yeah, i updated it.
A bit difficult, but i guessed it at last. The info on how to update was not all easy. But i tried to save the old content.html to content.php after changing it to utf-8, anf then it worked.
So now i will just tjek if it all Works, and then do the other webpages later.

Re: CMSimple 2.9 and PHP 5.6

Posted: Sun 8. Mar 2015, 15:19
by Gert
Erik Lomholt-Bek wrote:The info on how to update was not all easy. But i tried to save the old content.html to content.php after changing it to utf-8, anf then it worked.

Ups ... you are right, I have forgotten it in the documentation for the Updates from old versions.

Thanks for the hint - I will add this hint immedialtely,

Gert

Re: CMSimple 2.9 and PHP 5.6

Posted: Sun 8. Mar 2015, 17:08
by Erik Lomholt-Bek
I also had to put all Pictures in Again, but that was easy enogh.