Update auf 4.4.4 Versionsprüfung fehlgeschlagen

CMSimple 4.0 und höher
Post Reply
rreinhardklein
Posts: 41
Joined: Mon 14. Jul 2014, 14:32

Update auf 4.4.4 Versionsprüfung fehlgeschlagen

Post by rreinhardklein » Wed 23. Jul 2014, 13:28

Habe einige meiner cmsimple Websites auf 4.4.4 upgedatet, alle von 4.4.3 auf 4.4.4. gingen klaglos und OK
Von 4.0 auf 4.4.4 habe ich jetzt ein kleines Problem. Website neu ist OK, aber es kommt die Meldung wenn ich bei
EInstellungen CSS Versionsprüfung klicke:
CMsimple Version 4.4.4
und darunter
Versionsprüfung fehlgeschlagen
Gleichzeitig habe ich auch das Plugin Fotoboxes auf neueste version gebracht
und das wird in der gleichen Anzeige nach update weiterhin als
"Eine neuere version ist verfügbar" angezeigt.
Das Plugin funktioniert aber tadellos.
Was kann ich tun?

Gert
Posts: 1152
Joined: Sun 18. Nov 2012, 14:18

Re: Update auf 4.4.4 Versionsprüfung fehlgeschlagen

Post by Gert » Wed 23. Jul 2014, 14:13

Hallo,

vermutlich musst Du nur den Browser Cache leeren:

http://www.cmsimple.org/forum/viewtopic.php?f=20&t=244

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

rreinhardklein
Posts: 41
Joined: Mon 14. Jul 2014, 14:32

Re: Update auf 4.4.4 Versionsprüfung fehlgeschlagen

Post by rreinhardklein » Wed 23. Jul 2014, 18:22

Nein- das hab ich schon getestet- auf anderen PC.s die auf der Site noch nie waren.
auch hier die selbe Anzeige, die neue Fotobox läuft aber tadellos auf der betreffenden Website
Image

Gert
Posts: 1152
Joined: Sun 18. Nov 2012, 14:18

Re: Update auf 4.4.4 Versionsprüfung fehlgeschlagen

Post by Gert » Wed 23. Jul 2014, 20:33

Hallo,

dann scheint auf diesem Server weder allow_url_fopen=on zu sein, noch cURL zur Verfügung zu stehen, dann funktioniert die Versionsprüfung nicht.

Du könntest den Provider fragen, ob auf diesem Webspace allow_url_fopen mit .htaccess oder per php.ini zu manipulieren ist, oder ob cURL aktiviert werden kann. Ansonsten ist es besser, die Versionsprüfung in der CMS Konfiguration zu deaktivieren,

Gert

PS: Oder funktioniert es bei einer Neuinstallation von CMSimple 4.4.4 auf diesem Server? (in einem Unterordner)

Dann müsste ich mal das Update prüfen ...
Gert Ebersbach | CMSimple | Templates - Plugins - Services

rreinhardklein
Posts: 41
Joined: Mon 14. Jul 2014, 14:32

Re: Update auf 4.4.4 Versionsprüfung fehlgeschlagen

Post by rreinhardklein » Wed 23. Jul 2014, 23:15

Habe weiterprobiert. Es könnte auch an den Servern liegen.
Werde Deinen Vorschlag einer 4.4.4 Neuinstallation in einem Subdirectory machen und sehen ob es auch den Fehler zeigt oder nicht.
Habe insgesamt 7 Domains mit CMSimple von 4.x auf 4.4.4 bei 3 Providern upgedatet.
Nur bei 2 Domains die auf world4you laufen haben das Problem, bei den anderen 5 bei domaindiscount24 und domainfactory zeigt sich das Problem nicht.
Die im oberen Beitrag genannten php EInstellungen sind auch bei world4you aktiviert. Aber nur nur dort läuft php 5.5.8.
Den php EInstellungs- Report, den cmsimple erzeugt, sende ich gerne per e-mail zu.
Last edited by rreinhardklein on Thu 24. Jul 2014, 14:38, edited 1 time in total.

rreinhardklein
Posts: 41
Joined: Mon 14. Jul 2014, 14:32

Re: Update auf 4.4.4 Versionsprüfung fehlgeschlagen

Post by rreinhardklein » Wed 23. Jul 2014, 23:35

Gleicher Fehler bei der Neuinstallation 4.4.4. auch mit dem Plugin Fotoboxes ver24
Liegt dann wohl an den Servereinstellungen?
Habe am Server versuchsweise auch auf php 5.4 zurückgestellt- ohne Änderung.

Hixi
Posts: 65
Joined: Sat 22. Dec 2012, 22:46

Re: Update auf 4.4.4 Versionsprüfung fehlgeschlagen

Post by Hixi » Sat 26. Jul 2014, 12:57

Hallo Gert

Wir haben auf 21 Pages auf den Update auf 4.4.4 installiert, es hat problemlos geklappt. :)

Ein schönes Wochenende und Grüsse aus der Schweiz

Beat + Susanne

Gert
Posts: 1152
Joined: Sun 18. Nov 2012, 14:18

Re: Update auf 4.4.4 Versionsprüfung fehlgeschlagen

Post by Gert » Sat 26. Jul 2014, 15:12

Hixi wrote:Wir haben auf 21 Pages auf den Update auf 4.4.4 installiert, es hat problemlos geklappt. :)
Hallo in die Schweiz, ich nehme mal an, das ganze hat keine Stunde gedauert ;)

Wenn php und die Serverbetreiber mich nicht dazu zwingen, werde ich diese einfachen Updates noch lange beibehalten. Aber irgendwann kommt die Notwendigkeit für CMSimple 5, und dann wird es ein etwas umfangreicheres Update geben müssen, das durch einfaches "drüberbügeln" nicht mehr durchführbar sein wird.

Im Augenblick sieht es aber nicht so aus, und es ist auch noch nichts in Richtung CMSimple 5 geplant.

@ Reinhard:

Das liegt wohl dann an irgendwelchen Sicherheitseinstellungen des Servers, die das öffnen "entfernter Dateien" verhindern. Somit können die version.nfo Dateien auf meinem Server nicht gelesen werden, und die Versionsprüfung scheitert,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

rreinhardklein
Posts: 41
Joined: Mon 14. Jul 2014, 14:32

Re: Update auf 4.4.4 Versionsprüfung fehlgeschlagen

Post by rreinhardklein » Sat 26. Jul 2014, 17:37

Danke- da die 2x cmsimple updates 4.4.4 ja problemlos auf dem betroffenen provider world4you funktionieren, ignorore ich das einfach.
Bei Nachfrage hat man mir gesagt dass ich die server php EInstellungen beim gewählten Tarif ausser die Version sowieso nicht ändern kann.

Post Reply