Reinstallation version 5.3

CMSimple 4.0 und höher
jack31
Posts: 41
Joined: Fri 19. Feb 2021, 20:54
Location: France

Reinstallation version 5.3

Post by jack31 » Sat 20. Feb 2021, 02:22

Hello to all,

I'm a new CMSimple user that I'm discovering and testing. A real pleasure ;)

With the study of the documentations and the help of these forums, I manage to understand and get results but of course I have a lot of questions as you can imagine. Lol!

My first tests made me break the site and I know it will happen again before I master the CMS. So my first question is...

Is there a way to reinstall it cleanly without deleting files and folders and emptying the database, which would avoid having to reinstall the modules and themes already in the system?

Thank you.

CMSimple 5.3
PHP 7.4.11

Sorry for my english. I'm French

Gert
Posts: 1531
Joined: Sun 18. Nov 2012, 14:18

Re: Reinstallation version 5.3

Post by Gert » Sat 20. Feb 2021, 08:47

Hi Jack,

with some fear I ask to myself, what the hell that guy wants to do with CMSimple? ;)
jack31 wrote:
Sat 20. Feb 2021, 02:22
My first tests made me break the site ...
I hope, you have backups of the folders content/ and userfiles/.

You can try to use the update:

https://www.cmsimple.org/en/?Downloads_ ... __CMSimple

That is a full CMSimple without content-, config- and languagefiles, simply copy it over the installation.

If the problem is in the content, try the backups restore function, in admin menu on top:

Settings => Backup

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

jack31
Posts: 41
Joined: Fri 19. Feb 2021, 20:54
Location: France

Re: Reinstallation version 5.3

Post by jack31 » Sat 20. Feb 2021, 11:44

Hello Gert and thank you for your answer :)

This guy wants to make a portal to gather a lot of his pages already online with a CMS without database.
He especially wants to replace his usual CMS of choice (pluxml.org) which, for subtle reasons, doesn't suit him anymore.
I hope, you have backups of the folders content/ and userfiles/.
Too late my friend, too late ;)

For the update, this is a new installation with CMSimple 5.3 so no need to update.

Note that I did two installations.

1) Via Softaculous directly from the hosting company
2) Direct download from the cmsimple.org website

I notice that, although in 5.3, the two archives are different because the one via Softaculous doesn't have the directories ./2site2lang ./2site and ./2author
In short, they are different and I must admit that the new user is a bit confused when he studies the documentation. :-//

Then came the crash but I'm waiting to reproduce it before coming here to talk about it.

Now I reload the whole thing and see what happens.

Gert
Posts: 1531
Joined: Sun 18. Nov 2012, 14:18

Re: Reinstallation version 5.3

Post by Gert » Sat 20. Feb 2021, 12:41

jack31 wrote:
Sat 20. Feb 2021, 11:44
For the update, this is a new installation with CMSimple 5.3 so no need to update.
You also can use the Update for a damaged installation, but mostly that is not the reason for problems.
jack31 wrote:
Sat 20. Feb 2021, 11:44
Note that I did two installations.

1) Via Softaculous directly from the hosting company
2) Direct download from the cmsimple.org website
Better use the original source from cmsimple.org,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

jack31
Posts: 41
Joined: Fri 19. Feb 2021, 20:54
Location: France

Re: Reinstallation version 5.3

Post by jack31 » Sat 20. Feb 2021, 12:46

Mieux vaut utiliser la source originale de cmsimple.org
Ok ! :)

My problem (at the moment) is that the wave3cols template makes me pages inopportunely and finally erases all my content without me asking for anything.

Any idea about this?

Image

Gert
Posts: 1531
Joined: Sun 18. Nov 2012, 14:18

Re: Reinstallation version 5.3

Post by Gert » Sat 20. Feb 2021, 14:21

Hello,

please deactivate the templateswitch plugin in the pluginmanager, or delete it, is the problem solved than?

Does it really happen only with that template?

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

Gert
Posts: 1531
Joined: Sun 18. Nov 2012, 14:18

Re: Reinstallation version 5.3

Post by Gert » Sat 20. Feb 2021, 14:38

Hello,

what a strange page structure :o

Have you played around with the CMS configuration?

Wait some minutes, I will make some testing,

Gert
Last edited by Gert on Sat 20. Feb 2021, 14:43, edited 1 time in total.
Gert Ebersbach | CMSimple | Templates - Plugins - Services

Gert
Posts: 1531
Joined: Sun 18. Nov 2012, 14:18

Re: Reinstallation version 5.3

Post by Gert » Sat 20. Feb 2021, 14:42

Hello,

you have misconfigured your CMSimple.

Go in the admin menu to Settings => CMS and set use => H1only_pagesplitting: to "true", an all will be ok again,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

jack31
Posts: 41
Joined: Fri 19. Feb 2021, 20:54
Location: France

Re: Reinstallation version 5.3

Post by jack31 » Sat 20. Feb 2021, 15:05

Yes, I'm playing with the configuration to study the trick, I disabled templateswitch and everything seems to be back to normal (with H1only_pagesplitting: on "true"), I don't know yet if everything is ok (waiting for more tests) and I'll tell you the results.

Question: To remove a Plugin. Do we delete its folder?

I'm currently translating a lang file into french; at the moment it's working.

When it's finished, I'll put the fr.php file in download for all.

On the other hand, when I test a new CMS, I usually edit a tutorial that I use to list tips and ways of doing things for future beginners. A kind of "how to" what.

I will put it online this afternoon as soon as I've finished the translation in French and will propose the link here.

Gert
Posts: 1531
Joined: Sun 18. Nov 2012, 14:18

Re: Reinstallation version 5.3

Post by Gert » Sat 20. Feb 2021, 15:17

jack31 wrote:
Sat 20. Feb 2021, 15:05
Question: To remove a Plugin. Do we delete its folder?
That is one option, but you also can deactivate it by pluginmanager. Just click in the admin menu direct on "plugins" and have a look.

You can activate the templateswitcher again now, that was not the reason for the trouble ;)

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

Post Reply