CMSimple 5.1 Problem mit dem Login

CMSimple 4.0 und höher
George
Posts: 6
Joined: Mon 7. Dec 2020, 10:32

Re: CMSimple 5.1 Problem mit dem Login

Post by George » Sat 12. Dec 2020, 13:23

Hi Gert,

ich habe den Fehler gefunden und wahrscheinlich damit auch das Problem gelöst.
Hier beschreibe ich mal, wie bei mir das Problem überhaupt entstanden ist:

Am 7.7.2020 habe ich mir unter https://www.cmsimple.org/?Downloads___U ... __CMSimple das CMSimple_Update_4-0_5-1.zip heruntergeladen. Da auf der Website nichts von einem zeitlimitierten Login bzw. nicht der Hinweis "Achtung: Bitte vor der Installation 'readme.txt' lesen!" stand, habe ich mein im Aufbau befindliches Webprojekt auf CMSimple 5.1 aktualisiert, ohne zuvor die readme.php zu lesen (hätte da readme.txt gestanden, hätte ich diese vermutlich gelesen). Wahrscheinlich ist damals das Login-Problem nicht aufgetreten, weil ich das Login innerhalb von fünf Minuten geöffnet und das Passwort geändert hatte. Mein Webprojekt ließ sich danach problemlos bearbeiten.

Als ich etwa fünf Monate später das Webprojekt fertigstellen wollte, kam nach Eingabe meines damals notierten Passwortes die Fehlermeldung „Fehler 401: Nicht erlaubt“. Dafür habe ich bis jetzt keine Erklärung. Hat das eigene Passwort ein Ablaufdatum?
Nach mehrmals vergeblichen Versuchen habe ich mir dann nochmals das Original CMSimple 5.1 heruntergeladen und in den Ordner xampp/htdocs kopiert. Wahrscheinlich habe ich nach dem Start des Programms das Zeitlimit überschritten, denn beim Login erhielt ich den Fehler "Error 401: Unauthorized".

Da ein anderes Webprojekt in CMSimple 5.0 bei mir problemlos funktionierte, nahm ich an, dass die Fehlerursache bei der Version 5.1 an meiner alten XAMPP-Version liegt. Aktuelle XAMPP-Versionen gibt es aber nur noch für 64-Bit-Systeme. Nach längerem Suchen fand ich dann doch noch eine Quelle für die letzte XAMPP-Version für 32-Bit.

Diese 32-Bit-Version installierte ich als xampp-7.3.2 parallel zur bestehenden alten Version und kopierte die vorhandenen Daten aus htdocs in die neue Version.
Dann startet ich über localhost CMSimple 5.1 mit dem Ergebnis, dass nach Login die Fehlermeldung "Error 401: Unauthorized" kam. Ich bin fast verzweifelt.

Erst als ich in ein funktionierendes CMSimple 5.0 die Inhalte der Ordner content/, userfiles/ und templates/ aus meinem 5.1-Webprojekt kopiert hatte und ich dann überhaupt keine Veränderungen beim Aufruf von CMSimple 5.0 mit localhost sehen konnte, wurde ich stutzig.
Beim Testen musste ich dann feststellen, dass localhost immer auf die Website-Daten der alten XAMMP-Version zugriff und nicht auf die der neuen XAMPP-Version. Deshalb konnten Gerts Vorschläge auch nicht fruchten.

Nachdem ich die neue XAMPP-Version gelöscht hatte, konnte ich mit der in readme.php beschriebenen Vorgehensweise ein neues Passwort vergeben, wobei ich aber vorher noch das auf 01.06.2020 stehende Dateidatum durch Zurückspeichen aktualisieren musste.

Danach funktionierte bei mir auch das Login bei der Version 5.1 zum Bearbeiten der Website. Das Problem scheint gelöst zu sein.

Meine Lehre daraus: Vor der Installation immer zuerst die readme-Datei lesen und niemals parallel ein zweites XAMPP auf einem Computer installieren.

Beim Anlegen dieses Threads im CMSimple-Forum hatte ich einige Schwierigkeiten. Um den Zugang zu diesem Forum benutzerfreundlicher zu machen, schlage ich folgende Verbesserungen vor:

1.) Damit man sich ohne langes Suchen im CMSimple-Forum anmelden kann, sollte neben oder unter "Login" ein "Register"-Link stehen mit direktem Ziel zur Anmelde-Seite https://www.cmsimple.org/registration/

2.) Auf dieser Anmelde-Seite oder in der eMail mit dem Passwort sollte stehen, wie man dieses Passwort ändern kann, also:
- mit dem erhaltenen Passwort einloggen
- rechts oben (unter Suche) auf den eigenen Benutzernamen klicken
- dann auf "Profil" klicken
- dann hinter Benutzernamen auf [ Profil ändern ] klicken
- dann auf "Registrierungsdetails ändern" klicken
- dann Neues Passwort eingeben und "Absenden" klicken.

George

Gert
Posts: 1514
Joined: Sun 18. Nov 2012, 14:18

Re: CMSimple 5.1 Problem mit dem Login

Post by Gert » Sat 12. Dec 2020, 17:00

Hallo George,

Danke für das Feedback.
George wrote:
Sat 12. Dec 2020, 13:23
Meine Lehre daraus: Vor der Installation immer zuerst die readme-Datei lesen und niemals parallel ein zweites XAMPP auf einem Computer installieren.
Ich habe auf meinem PC 3 Xampp mit unterschiedlichen php Versionen installiert. Man muss Dateioperationen natürlich in dem Xampp ausführen, welches man gestartet hat ;)

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

George
Posts: 6
Joined: Mon 7. Dec 2020, 10:32

Re: CMSimple 5.1 Problem mit dem Login

Post by George » Sat 12. Dec 2020, 18:43

Hi Gert,

bei meinen Versuchen hatte ich natürlich nur die neue XAMPP-Version gestartet.
Ich glaube es lag daran, dass ich der neuen Version dieselben Ports zugeteilt hatte wie der alten.
localhost kann scheinbar nur dann wissen, welche Version gemeint ist, wenn die Ports unterschiedlich sind. Also localhost:8080 und localhost: 8081.
Egal woran es genau lag, als gebranntes Kind werde ich keine zweite XAMPP-Version mehr auf meinem Computer installieren.

George

Post Reply