Upload Bilder

CMSimple 4.0 und höher
Furrer
Posts: 8
Joined: Thu 14. Aug 2014, 21:34

Upload Bilder

Postby Furrer » Sat 28. Oct 2017, 07:02

Hallo
Ich hab ein Problem mit meiner Homepage www.stefanstanz.ch
Grundsätzlich funktioniert die Homepage. Aber ich kann keine Bilder in die Homepage einfügen, da der Ablageort nicht gesucht werden kann im Auswahlfenster. Auf dem Server sind diese vorhanden.

Hab CMSimple Version 4.4

Zur Information
Auf der Datenbank hab ich mehrere Homepages. Die Daten für die Homepage sind in einem Unterverzeichnis abgelegt
Wenn es notwendig und mir vertrauenswürdigerweise helfen möchte, ist kann ich auch das Passwort bekanntgeben, damit jemand auf meine CMSimple-Homepage schauen kann und prüfen was los ist.

meine Email lautet: hubert.furrer@bluewin.ch

Vielen Dank

Hubert Furrer

Gert
Posts: 1031
Joined: Sun 18. Nov 2012, 14:18

Re: Upload Bilder

Postby Gert » Sat 28. Oct 2017, 07:43

Hallo,

Furrer wrote:Hab CMSimple Version 4.4

Da wäre als erstes ein Update auf CMSimple 4.7.2 zu empfehlen:

https://www.cmsimple.org/?Downloads___Updates___CMSimple

Furrer wrote:Aber ich kann keine Bilder in die Homepage einfügen, da der Ablageort nicht gesucht werden kann im Auswahlfenster.

Grundsätzlich kann man auch mit CMSimple 4.4 jedes Bild aus dem www einfügen, man muss halt den URL kennen und zur Not von Hand eingeben. Es geht aber auch per Dialogfenster, mit dem kleinen Icon neben "Image URL", allerdings müssen die Bilder im Ordner ./userfiles/images liegen. Dahin werden Bilder auch von CMSimple hochgeladen.

Wenn das bei Dir nicht funktioniert, warum merkst Du das erst jetzt? CMSimple 4.4 ist von 2014 ...

Gert

==========================================

PS: Du kannst ja mal versuchen, in der CMS Konfiguration die userfiles-Ordner zu manipulieren, dann könnte es zumindest innerhalb der Domain klappen.
Gert Ebersbach | CMSimple | Templates - Plugins - Services

Furrer
Posts: 8
Joined: Thu 14. Aug 2014, 21:34

Re: Upload Bilder

Postby Furrer » Sat 28. Oct 2017, 10:02

Hallo Gert

Gute Frage: warum ich das erst jetzt merke ...
Ich musste die Server-Konfiguration anpassen (neue Zugangsdaten)
Aber an der Struktur hat sich eigentlich nichts geändert
Genau, im Dialogfenster kann ich das Verzeichnis (... images) nicht aufrufen, sondern es erscheint die Fehlermeldung, wenn ich das Icon "Image URL" verwende

***Fehlermeldung*******************************************************************************************
Objekt nicht gefunden!

Der angeforderte URL konnte auf dem Server nicht gefunden werden. Sofern Sie den URL manuell eingegeben haben, überprüfen Sie bitte die Schreibweise und versuchen Sie es erneut.

Sofern Sie dies für eine Fehlfunktion des Servers halten, informieren Sie bitte den Webmaster hierüber.
***************************************************************************************************************

Zur Not: wie müsste ich die URL eingeben, damit ich die Bilder laden könnte

Werde dann mal das Update fahren, muss aber unbedingt die Homepage aktualisieren, da der Event ja auch bald stattfindet

Vielen Dank für die Hilfe

Gruess Hubi

Gert
Posts: 1031
Joined: Sun 18. Nov 2012, 14:18

Re: Upload Bilder

Postby Gert » Sat 28. Oct 2017, 10:18

Furrer wrote:Zur Not: wie müsste ich die URL eingeben, damit ich die Bilder laden könnte

Wenn das Bild im Ordner ./userfiles/images/ liegt, dann ./userfiles/images/bild.jpg

Ansonsten geht auch http://www.stefanstanz.ch/templates/gefluidbusiness1XH/images/logo.jpg - also der volle URL des Bildes.

==========================================

Überprüfe mal Deine userfiles Konfiguration in der CMS Konfiguration, da muss stehen:

Folders

Userfiles: userfiles/
Downloads: userfiles/downloads/
Images: userfiles/images/
Media: userfiles/media/

Die Pfade werden vom CMSimple Installationsverzeichnis aus referenziert (CMSimpleRoot). Du kannst auch andere Pfade eintragen, aber die Ordner müssen schon existieren, und auf manchen Servern auch auf 0777 gesetzt sein, dann sollte es eigentlich auch im Dialogfenster funktionieren,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

Furrer
Posts: 8
Joined: Thu 14. Aug 2014, 21:34

Re: Upload Bilder

Postby Furrer » Sat 28. Oct 2017, 13:35

Hallo Gert

Vielen Dank für deinen Support

Das mit der manuellen Eingabe der URL funktioniert; ein wenig mühsam aber es geht
Er hat das erste Mal aber das Passwort des Web-Servers verlangt. Deutet dies auf ein Zugriffsproblem hin auf dem Server?

Werde nun mal die Homepage aktualiseren, dann die neuste Version einspieln und dann wieder schauen
Ev. meld ich mich dann wieder

Gruess Hubi

Furrer
Posts: 8
Joined: Thu 14. Aug 2014, 21:34

Re: Upload Bilder

Postby Furrer » Sat 28. Oct 2017, 17:10

Hallo Gert

hab nun die Bilder via Angabe der URL importiert
Nun frägt er beim ersten Aufruf nach dem Server-Passwort
Hat du eine Idee, wo eine Freigabe fehlen könnte; Server-Konfiguration, CMSimple oder sonst wo

Vielen Dank

Hubi

Gert
Posts: 1031
Joined: Sun 18. Nov 2012, 14:18

Re: Upload Bilder

Postby Gert » Sun 29. Oct 2017, 08:59

Hallo Hubi,

ich glaube, jetzt ist es an der Zeit, beim Serverbetreiber nachzufragen.

Natürlich solltest Du zuvor Dein CMSimple auf den aktuellen Stand bringen. Zum Beispiel ist CMSimple erst ab Version 4.6.1 fit für php 7. Trotzdem habe ich jetzt mal CMSimple 4.4 auf einem php7 Server installiert - Bilder hochladen und einfügen läuft problemlos, auch per Bilddialog des Editors.

Welche php Version läuft auf Deinem Server?

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services


Return to “CMSimple 4.0 and higher”

Who is online

Users browsing this forum: No registered users and 1 guest