Frage zu MembersArea

Erweiterungen
Post Reply
jkubens
Posts: 2
Joined: Wed 15. Oct 2014, 00:56

Frage zu MembersArea

Post by jkubens » Wed 6. May 2015, 16:33

Hallo und guten Tag,

auf unserer Seite http://www.solardrums.de habe ich auch das Plugin MembersArea installiert.
Es arbeitet wie gewünscht, ich muss mich mit Paßwort anmelden, dann bin ich im internen Bereich und kann mich abmelden.
So weit so gut, aber:
Wenn ich in der Suchmaschine einen Namen einer Person aus der Adressdatei eingebe die im paßwortgeschützten Bereich gespeichert ist, zeigt die Suchmaschine die ganze eigentlich geschützte Seite an.
Probiert es mit meinem Namen aus.
Sucht nach - Jürgen Kubens solardrums - und ihr bekommt die eigentlich geschützte Seite angezeigt. (Im Moment steht nur meiner drin)
Das dürfte ja eigentlich nicht sein, oder?
Das PlugIn ist nach Installationsanleitung installiert. Was könnte ich falsch gemacht haben?
CMSimple 4.5 Released: 2014-11-28
membersarea Aktuelle Version ist installiert (2.2)

Ich freue mich auf Hinweise,
Grüße von Jürgen

Gert
Posts: 1246
Joined: Sun 18. Nov 2012, 14:18

Frage zu MembersArea

Post by Gert » Wed 6. May 2015, 17:16

Hallo Jürgen,

Du musst jede einzelne Mitgliederseite mittels Plugin Aufruf schützen :!:

Eine Seite auf der an irgendeiner Stelle dieser Plugin Aufruf eingefügt ist, ist nur für eingeloggte Mitglieder der Gruppen member und VIP sichtbar:

Code: Select all

{{{plugin:membersarea_protect('!member!VIP!');}}}
Diese Seite:

http://www.tucanu.de/solardrums/?Intern ... erAdressen

ist wahrscheinlich NICHT geschützt.

So sieht eine mit MembersArea geschützte Seite aus, wenn man sie aufruft und dabei nicht eingeloggt ist:

http://www.ge-webdesign.de/plugindemo/? ... ppe_member

In der Plugin Hilfe kannst Du das unter 4.2 nachlesen:

http://www.tucanu.de/solardrums/plugins ... elp_de.htm

Gert

======================================================

PS: Alle Deine Mitgliederseiten sind ja auch im Inhaltsverzeichnis sichtbar:

http://www.tucanu.de/solardrums/?&sitemap

Da ich nun davon ausgehe, dass keine Deiner Mitgliederseiten den erforderlichen Code enthält, handelt es sich also nicht um ein "Sicherheitsproblem", sondern um einen Anwenderfehler, resultierend aus "nicht lesen der Hilfedatei" ;)

Deshalb habe ich Deinen Thread umbenannt.
Gert Ebersbach | CMSimple | Templates - Plugins - Services

jkubens
Posts: 2
Joined: Wed 15. Oct 2014, 00:56

Re: Frage zu MembersArea

Post by jkubens » Mon 11. May 2015, 17:54

Hallo Gerd,

vielen Dank für die Nachhilfe. :P

Mir war nicht klar dass der Code auch auf jede Unterseite eingefügt werden muss.
Jetzt ist er drin, und die Seite auch nicht mehr erreichbar.

Grüße von Jürgen

Post Reply