Page 1 of 1

PLUGIN kommand gives no action

Posted: Wed 26. Nov 2014, 14:17
by lwinther
I have for some time tried to install the multimedia plugin.
I have careffully downloaded, unpacket and uploaded the plugin and changed the file protections after upload as described.
In the CM Simple editor I write the PLUGIN command on a blank line, save the page, leaves edit mode.
When I go to the page, vhere the plugin is defined, there are no multimedia player. Instead the PLUGIN command stands as text on the page
(i.e. is not recognized and executed as a plugin call). If I go back to edit mode and look at the HTML code, the editor has put a <P></P> tag arount the command). I have tried to delete the P tags in HTML mode, but as soon as I press update, the P tags are inserted Again. Dont know how it should be.

The Plugin command that I use goes like this:

H2 page header

Some text....

PLUGIN:mp3_play('followme.mp3', '332', '90', 'none', '0', '0');

More text.....

But it all comes out as text.

What am I doing wrong?

Lars Winther

Re: PLUGIN kommand gives no action

Posted: Wed 26. Nov 2014, 14:31
by Gert
Hi Lars,

what you are doing :?:

Please do not insert linebreaks:

{{{plugin:mp3_play('followme.mp3', '332', '90', 'none', '0', '0');}}}

Which CMSimple Version you have installed? The current CMSimple should replace the <p> arround the Plugin Call automatic by <div>, but only if the Plugin Call is correct.

In older Versions you can write in sourcecode mode:

Code: Select all

<div>{{{plugin:mp3_play('followme.mp3', '332', '90', 'none', '0', '0');}}}</div>
But please consider: The MultiMedia Plugin is based on Flash, that's a deprecated Standard in the www, not supported anymore on many Systems, for example on Smartphones, Tablets etc. it will not work.

Better use the MultiMedia2 Plugin: ... udioPlayer


Re: PLUGIN kommand gives no action

Posted: Wed 26. Nov 2014, 16:13
by lwinther
Thank you,

it Works now (without the <div></div)

Problem was: the entire command including {{{}}} MUST be on the same line, and with nothing else in that line.
When the entire command is in one line in the editor, it puts af <code></code> tag around it in the HTML code.
I use CMSimple version 4.4.3