TemPlug Templates - Sicherheitsupdate - security update

Designvorlagen
Post Reply
Gert
Posts: 1128
Joined: Sun 18. Nov 2012, 14:18

TemPlug Templates - Sicherheitsupdate - security update

Post by Gert » Sun 18. May 2014, 16:16

Image Hallo,

in den letzten Wochen sind Sicherheitsprobleme mit CMSimple bekannt geworden, die auftreten können, wenn register_globals = ON ist. Diese Einstellung wird es in kommenden php Versionen nicht mehr geben, trotzdem habe ich das Sicherheitsloch in CMSimple 4.4.2 geschlossen.

Das gleiche Problem (wie gesagt, nur wenn register_globals = ON ist, eine eigentlich nicht mehr übliche Einstellung) besteht auch bei den TemPlug Templates. Ich habe alle meine TemPlug Templates dahingehend untersucht und neue Downloads hochgeladen, damit CMSimple mit TemPlug Templates auch in php Versionen kleiner als 5.4 und mit register_globals = ON sicher ist.

Downloads: http://www.ge-webdesign.de/cmsimpletemplates/?TemPlug

Ihr könnt Eure bereits bearbeiteten TemPlug Templates updaten, indem Ihr das entsprechende Basis Template neu downloaded und folgende Dateien aktualisiert:

./templates/tp_Das_Template/templug/alle Dateien
./templates/tp_Das_Template/templug/functions/tp_functions.php

Die neuen Dateien sind gegen direkten Zugriff geschützt.

Ausserdem habe ich die Templates für mobile Geräte mit Touchscreens optimiert, grössere Abstände zwischen den Links und den Flaggen im Sprachmenü (für dicke Finger) usw.,

Gert

========================================================================

Image Hello,

in the last weeks, security problems with CMSimple have become known which may occur if register_globals = ON. This setting will no longer be available in upcoming versions of php, but I have closed the security holes in CMSimple 4.4.2.

The same problem (as I said, only if register_globals = ON - not really a usual setting anymore) is probably in the TemPlug templates. I have checked all TemPlug templates and uploaded new downloads, so that CMSimple with TemPlug templates is also safe in php versions earlier than 5.4 and with register_globals = ON.

Downloads: http://www.ge-webdesign.de/cmsimpletemplates/?TemPlug

You can update your already edited TemPlug templates, download the corresponding template and update the following files:

./templates/tp_the_template/templug/alle Dateien
./templates/tp_the_template/templug/functions/tp_functions.php

The new files are protected against direct access.

I also have optimized the templates for mobile devices with touchscreen, more space between links and language flags (for fat fingers) and so on,

Gert
Gert Ebersbach | CMSimple | Templates - Plugins - Services

Post Reply