Page 1 of 1

Administration of LANG sub-sites not work

Posted: Wed 18. Mar 2015, 22:08
by zeman
Hello,

I have problem with ADMINISTRATION of multiple language sub sites.

My main site is in slovak SK then DE,EN.

Image

Sub sites are working properly, root site is in SK, config.php from subsites /en and /de was removed.

Image

But after login on main site (SK) I cannot edit subsites (EN,DE), after loging on DE I cant edit (SK,EN)

Did I something wrong ?

My site run on php 5.2.17

Thanks.

Re: Administration of LANG sub-sites not work

Posted: Thu 19. Mar 2015, 08:03
by Gert
zeman wrote:Did I something wrong ?

Hi zeman, unfortunately I have no idea ... check following:

1. Are all language subsites copys of 2lang?

2. You have to set default_languge to "sk" for all 3 languages (CMS Konfiguration) - its own language a subsite/secondary language recognices itself, by the folder name.

3. What do you mean with "I cannot edit"? No save? No change? No editor? No login?

4. Are you working in 3 tabs (all languages open) or switching by flag menu?

Please give some more deatiled informations, and if yo want, send me link and password(s) by PM, so I can have a look,

Gert

Re: Administration of LANG sub-sites not work

Posted: Thu 19. Mar 2015, 23:55
by zeman
Hi zeman, unfortunately I have no idea ... check following:

1. Are all language subsites copys of 2lang?
Yes.
2. You have to set default_languge to "sk" for all 3 languages (CMS Konfiguration) - its own language a subsite/secondary language recognices itself, by the folder name.
SK is default language of root site, others are /de and /en. As you can see on screenshot up side.
3. What do you mean with "I cannot edit"? No save? No change? No editor? No login?
I can administrate only one site at time, my goal is administrate whole site by one login.
4. Are you working in 3 tabs (all languages open) or switching by flag menu?
Yes, by flags.
Please give some more deatiled informations, and if yo want, send me link and password(s) by PM, so I can have a look,
OK, Thank You
Gert

Re: Administration of LANG sub-sites not work

Posted: Fri 20. Mar 2015, 00:56
by Gert
zeman wrote:SK is default language of root site, others are /de and /en. As you can see on screenshot up side.

You have to set sk as default language in all 3 languages (CMS configuration), because sk is the default language for all 3.

zeman wrote:I can administrate only one site at time, my goal is administrate whole site by one login.

That's not possible. Every subsite and second language has its own login. You can open all 3 instances in 3 different tabs or switch, but you have to login to every single instance,

Gert

Re: Administration of LANG sub-sites not work

Posted: Fri 20. Mar 2015, 12:02
by zeman
Okay, thanks, now i understand how it works.